Hesperus Crimean (merkyl) wrote,
Hesperus Crimean
merkyl

Глюки полнотекстового поиска после перехода с 8.1 на 8.3

Оригинал взят у fixin в Глюки полнотекстового поиска после перехода с 8.1 на 8.3


Перевел УТ с 8.1 на 8.3. Обнаружилась ошибка. Когда пользователь щелкан на результате полнотекстового поиска, он не открывался, писал ошибку:


{Обработка.ПоискДанных.Форма.Форма.Форма(156)}: Преобразование значения к типу Число не может быть выполнено номерВСписке = Число(htmlElement.nameProp);





Отладка показала, что свойство nameProp уже не содержит номер объекта в списке. Поковырялся, нашел, что оно все же есть в другом месте, в атрибуте sel_num.


Пришлось добавить код:



Вот код текстом, если кому надо:


Процедура HTMLОтображениеonclick(Элемент, pEvtObj)
 
 htmlElement = pEvtObj.srcElement;
 
 Если (htmlElement.id = "FullTextSearchListItem") Тогда
  номерВСписке = Неопределено;
  Попытка
   номерВСписке = Число(htmlElement.nameProp);
  Исключение
   Попытка
    номерВСписке = Число(htmlElement.getattribute("sel_num"));
   Исключение
   КонецПопытки;
  КонецПопытки;
  
  Если номерВСписке <> Неопределено Тогда
   ВыбраннаяСтрока = списокПоиска[номерВСписке];
   ОткрытьЗначение(ВыбраннаяСтрока.Значение);
  
   pEvtObj.returnValue = Ложь;
  КонецЕсли;
 КонецЕсли;
 
КонецПроцедуры


Глюки 1с - они такие глючные! ;-)


Subscribe
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 0 comments